Чтение RSS

apt-get требует диск при установке пакета

При попытке установки пакета текстового редактора vim командой apt-get install vim пакетный менеджер требует cd диск, а не ищет пакет в онлайн репозитории.

 

Смена носителя: вставьте диск с меткой
 «Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 xfce-CD Binary-1 20180714-10:25»
в устройство «/media/cdrom/» и нажмите [Enter]

Для того, чтобы apt-get начал искать пакет в интернете необходимо в текстовом редакторе (например nano) открыть файл /etc/apt/sources.list и закомментировать строки

 

# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 xfce-CD Binary-1 $
# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 xfce-CD Binary-1 2$

Затем сохранить файл и apt-get начнет скачивать пакеты из указанного в этом же файле онлайн репозитория.

Вернуться